Livestream Forum

Livestream Forum (
-   Feedback (
-   -   Built a new machine specifically for LiveStream. Nothing but problems (

themajesticking 24th February 2013 12:08

Built a new machine specifically for LiveStream. Nothing but problems
Hi. I'm a new LiveStream member. My church tasked me with setting up LiveStream for our services. I built a new machine with a Core i7 3770k, 8GB ram, 128GB SSD. I would imagine that this machine is powerful enough to broadcast at AT LEAST "high" settings. When broadcasting at "high" LiveStream for Producers reports my CPU usage at no more than 9%. However, whenever I try to broadcast at "High or even Medium", the stream will stop and I get an error message saying that my CPU is unable to encode at the requested bitrate and that I should try lowering the bitrate. This is ridiculous. I've tried everything. My CPU has never peaked higher than 15% regardless of which bitrate I choose. I've tried uninstalling just about every piece of software on the system to make sure there is no conflict but I can't figure this out. I've been pulling my hair out for 3 weeks now. I have both a BlackMagic ATEM switcher and a Intensity Pro capture card. I've tried streaming with both and I get the same results either way.

This is frustrating since I can't call support because I pay for Basic service instead of Premium. I couldn't even post in the forum without creating a free "Old Livestream" account because the New Livestream login wouldn't work for the forums. I built my entire setup based on using LiveStream and at this point I feel like I need to look elsewhere. Please help.

Setup Specs:

Intel Core i7 3770k
8GB Corsair Dominator 1600 Ram
120GB Samsung SSD
BlackMagic ATEM Production Switcher
BlackMagic Intensity Pro PCI-E Card
2 Canon G10 1080p Cameras
Internet Speed - 50Mb down/10Mb up

ernielive 25th February 2013 12:24


Which version of Procaster are you running (Preferences > italic 'i')? Which is the exact quality setting that sends your CPU over the top? Please Procaster's default quality settings are as follows:

Medium + Mobile
High + Medium + Mobile
HD + Medium + Mobile
HD + High + Medium + Mobile

Your CPU should be able to handle the top quality setting, HD + High + Medium + Mobile.

themajesticking 25th February 2013 22:19

Version is (LiveStream for Producers - v0.0.56p)

My CPU never max's out. As a matter of fact even at HD settings it never goes above 30% so I have no idea why I get that message every time. The higher the settings, the faster the message appears. Sometimes I can go very long at medium settings but no longer than 5 minutes at high or HD.

themajesticking 25th February 2013 22:24

I also tried using the latest version of Procaster and I created a free test account to see if the issue was specific to LiveStream for Producers. I got the same results but it took longer to get the message. I was able to stream in HD for about 3 minutes before it gave me the message.

cedarcreektv 25th February 2013 22:44

Interesting issue... I just built an encoder with similar parts and have had great results for my church. We've streamed 24/7 for about 2 weeks now...

Here's my setup:

Asus P8Z77-M motherboard
Core i7-3770K CPU
Samsung Pro 840 SSD 256GB (support told me SSD wasn't necessary)
16GB DDR3 1600Mhz Kingston RAM (2x8GB)
Windows 7 Pro SP1 64bit
BlackMagic Decklink Studio (PCI-E x1) Card
1080i content coming in via HD-SDI with embedded audio

So, same CPU, possibly same SSD with a different capacity... Like you I only hit about 30% with all 4 going (HD, High, Medium, Mobile) at once. I don't get any errors though.

If yours is saying the CPU can't encode fast enough, I would start by ensuring you have the latest chipset drivers installed for your motherboard. Intel's IvyBridge setups will work natively with Windows 7, but the updated drivers do wonders for performance. You can get the latest from Intel's website, or possibly from the motherboard's manufacturer's site.

You should also ensure the drivers/software are fully updated for the Intensity Pro card if that's your ingest point. I'm not familiar with that product but have had great success with the Decklink cards (though they are touchy in various motherboards, which is why I ended up going with the Asus listed above as I know it works).

Also, what TYPE of internet is that? 50d/10u is plenty, but is it a fiber or cable modem of some kind? The error isn't indicating the bandwidth is a problem, but bandwidth QUALITY matters too.

Are you recording to the local drive or have you unchecked that option in the settings? I don't record because I have no need to... but perhaps this is causing an issue for you?

Lastly, did you install any other software like an anti-virus or firewall of some kind? Anything else that could be running spikes on the CPU?

themajesticking 2nd March 2013 06:47

That is very interesting. Thanks for the info. It's good to hear from someone with a similar setup. Gigabyte's website isn't the best when it comes to drivers. That could very well be part of the problem. As you stated, our setups are very similar. I've uninstalled just about everything so I'm sure there isn't a software conflict. However, I'm wondering if the motherboard is my issue. I haven't really received much help from Livestream support. Internet service is Comcast Business Class. I haven't noticed a record button in Livestream for Producers. Where is it?

themajesticking 2nd March 2013 20:22

Ok. Here's the deal. First, thanks so much CEDARCREEKTV. If you didn't post with almost the same specs saying it worked fine for you, then I probably wouldn't have had the patience to fix the issue. I actually use the machine remotely using RDP so I'm rarely in front of it. Today, I decided to take a trip down to the church and try some things out. Here are some of the things I did.

1. Purchased and installed a Cooler Master Plus cooler for the CPU. This wasn't completely necessary but I didn't want temps to be an issue. Temps never pass 48 degrees celcius at full load.

2. Downloaded the latest chipset drivers from Intel. My motherboard is a Gigabyte Z77x-UD3H by the way. So we have the same chipset. :)

3. Downloaded CPUID and HWMonitor in order to monitor some things. I noticed that my cpu core voltage seemed to hang around .800 instead of 1.1. Also, my core clock was 3.7ghz instead of 3.5ghz. So I decided to go into the BIOS and make some changes. I changed my core voltage setting from "Normal" to "Auto". I have no idea what Gigabyte was going for with that. I guess it adjusts automatically. If I could do it all over again, I wouldn't have purchased a Gigabyte board. I'm also having some grounding issues with this board. The multiplier is set to 35 so I have no idea why it's reading 3.7ghz. My theory is that the 3.7 mixed with a voltage of .800 was a recipe for disaster and made my cpu unstable even though it never maxed out.

Long story short, it's working fine now. :D I'm so happy. I was able to stream HD/High/Medium without a problem and the cpu usage never goes pass 30%. I was also able to use the ATEM switcher software to capture video while streaming and it still worked fine. It also works when using RDP as well. I think the culprit was the core voltage.


themajesticking 3rd March 2013 13:13

Nevermind. It still crashes when used over RDP. But it doesn't shut off when I'm logged in physically in front of the machine.

cedarcreektv 18th March 2013 11:42

Definitely sounds like a mobo issue though... Good catch on the voltage.

As for the RDP having issues, that's introducing a whole new can of worms with the user being logged off locally, on remotely, graphics drivers being changed over, and driver sharing over the connection for speakers/printers, etc... You also lose color scheme info and various other changes take place. Mine works over RDP, but it breaks some of the automation I have with a macro program that starts/stops my encoder on a schedule.

For troubleshooting, if it is stable out of RDP, but crashing with RDP, try using a remote access client that doesn't log out the user (such as or TeamViewer) instead.

All times are GMT -4. The time now is 02:49.